re = /^[a-zA-Z\u3000-\u303F\u3040-\u309F\u30A0-\u30FF\uFF00-\uFFEF\u4E00-\u9FAF\u2605-\u2606\u2190-\u2195\u203B]+$/m
str = '北海道AB
Kantname
北海道'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end