#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^|\s)#(\w+)"
Local $sString = "To take this -> #test" & @CRLF & _
"#test <- to take this" & @CRLF & _
"to take this #test another word" & @CRLF & _
"to take this #Mest another word" & @CRLF & _
"To don't take this -> l'#09" & @CRLF & _
"to don't take this -> » or '"
Local $sSubst = "$1<a href="/hash/$2" class='hash_tag'>#$2</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)