re = /\[\[https?:\/\/(*SKIP)(*FAIL)|\[\[\K[^][|]+(?=(?:\|[^][]*)?]])/m
str = '[[my_page]]
[[my_other_page|this is my other page]]
[[http://your_page|this is your page]]
[[my_other_page|this is my other page'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end