import Foundation
let pattern = #"((\d{1,2})\s?(hab|dorm|cuart))"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
VENTA de 3 AMBIENTES AL FRENTE 1 “A” , APTO PROFESIONAL, de 60 m2 cubiertos y 13 m2 semicubiertos de balcón aterrazado.Baño completo y toilette."CULLEN 5824" EDIFICIO CON ENTREGA INMEDIATA. LISTO PARA ESCRITURAR."ESPECIFICACIONES DE UNIDADES DE 3 AMBIENTES :Piso de porcelanato en linving y palier de distribución.Piso porcelanato símil madera en dormitorios.Pisos de cerámicas porcelaniticas color a definir en baños, balcones y cocina.Calefón a gas con encendido eléctrico.Horno embutido eléctrico y anafe a gas. (unidades separadas).Espejos en baños. Artefactos de 1ra. calidad tipo Ferrum ó Roca.Cerramientos línea Módena blanco.Mesada de granito y muebles bajo mesada y alacenas en cocinas.Placares de 2 Hojas corredizas, una hoja espejada.Pre instalación para colocación de aire acondicionado frío /calor en living y dormitorios.Cañería exclusiva para cable /TV (2) y telefonía independientes e interconectadas en unidades.ESPECIFICACIONES TÉCNICAS GENERALES DEL EDIFICIO EN CONSTRUCCIÓN:Terraza con parrilla, mesada de granito con bacha de acero y ducha.Portón automático en acceso a cocheras.Frente acceso en acero inoxidable, blindex.Ascensor con cabina de acero inoxidable.Hall de acceso al edificio y pallieres pisos de porcelanato pulido color a definir.COCHERAS OPCIONALES EN U$S 28.000Transportes CercanosColectivos:90, 107, 111, 114, 127, 140, 169PRECIO PAGO AL CONTADO: FORMA DE PAGO A CONVENIR, CONSULTE SALDO CON FINANCIACIÓN PROPIA.Necesitas mas información? Necesitas vender tu propiedad para comprar? esperamos tu llamado para asesorarte.GONZALEZ INMUEBLES Instagram: @gonzalez_inmueblesFacebook: gonzalez
ID: 221464
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)