using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|\s)\b";
string substitution = @"\1+";
string input = @"John Doe";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}