re = /<.*?>(.*?)</
str = '<div> hello world </div>
//comments
<div> bye world</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end