$re = '/(\d+_.*)-/m';
$str = '123456_John Smith-00001.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);