$re = '/^[+][0-9]{2}$/m';
$str = '+00
+49
+99
+100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);