$re = '/^(apple)/m';
$str = 'this applesauce is delicious
apple is delicious';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);