import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b # Leading marker\n"
+ "(?P<byte> # Define a full byte\n"
+ "25[012345] | # the numers 250 - 255 or\n"
+ "2[01234](?P<digit>[0123456789]) | # 200 - 249 or\n"
+ "1(?&digit){2} | # 100 - 199 or\n"
+ "#0? # Allow leading zero\n"
+ "[1-9](?&digit) | # 10 - 99 or\n"
+ "#0{0,2} # Allow leading zeros\n"
+ "(?&digit) # 0 - 9\n"
+ ") # close one full byte\n"
+ "(\\.(?&byte)){3} # Repeat three more bytes.\n"
+ "\\b # Trailing marker";
final String string = "0.0.0.0 00.00.00.00 000.000.000.000\n"
+ "1.2.3.4 01.02.03.04 001.002.003.004\n"
+ "11.22.3.44 11.22.03.44 011.022.033.044\n"
+ "23.34.34.5 23.34.34.05 123.234.034.005\n"
+ "1.1.192.168 01.01.192.168 001.001.192.168\n"
+ "text 123.234.34.123 more text\n"
+ "text123.234.34.123more text\n"
+ "1.2.3.255\n"
+ "1.2.3.256\n"
+ "255.255.255.255\n"
+ "256.2.3.4\n"
+ "1123.234.34.123\n"
+ "123.234.34.1235\n"
+ ".123.234.34.123\n"
+ "123.234.34.123.\n"
+ "not 1.1.168.192 in 1.1.168.192.in-addr.arpa.\n"
+ "not 1.14.2.90 in xserver-common_1.14.2.901-2_all.deb\n"
+ "1.2.3.4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}