re = /^(([^<>()\[\]\\.,;:\s@"]+(\.[^<>()\[\]\\.,;:\s@"]+)*)|(".+"))@(\[?(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})\]?|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$/m
str = 'asad.aa@test.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end