$re = '/\(\K\d+/';
$str = '23 asdasdasdasd.sma(33) asda sdas asd 23 2 3 54232 23d asd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);