re = /\b\d{4}-\d{2}-\d{2}\b/m
str = 'I have a String field like that "/etc/opt/eset/esets/license/esets_abd9c6.lic: ESET File Security, 2019-07-29 00:00:00, Mynet" and I need to capture the date value from that field, but I couldn\'t figure it out. '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end