const regex = /(https?)?(:\/\/)?(www\.)?[-a-zA-Z0-9@:%._\+~#=]{1,256}\.[a-zA-Z0-9()]{1,6}\b([-a-zA-Z0-9()!@:%_\+.~#?&\/\/=]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?)?(:\\\/\\\/)?(www\\.)?[-a-zA-Z0-9@:%._\\+~#=]{1,256}\\.[a-zA-Z0-9()]{1,6}\\b([-a-zA-Z0-9()!@:%_\\+.~#?&\\\/\\\/=]*)', 'gm')
const str = `http://bbc.co.uk/metus/aenean/fermentum.jpg?ipsum=massa&integer=id&a=lobortis&nibh=convallis&in=tortor&quis=risus&justo=dapibus&maecenas=augue&rhoncus=vel&aliquam=accumsan&lacus=tellus&morbi=nisi&quis=eu&tortor=orci&id=mauris&nulla=lacinia&ultrices=sapien&aliquet=quis&maecenas=libero&leo=nullam&odio=sit&condimentum=amet&id=turpis&luctus=elementum&nec=ligula
edublogs.org/augue/luctus.html?feugiat=pellentesque&et=eget&eros=nunc&vestibulum=donec&ac=quis&est=orci&lacinia=eget&nisi=orci&venenatis=vehicula&tristique=condimentum&fusce=curabitur&congue=in&diam=libero&id=ut&ornare=massa&imperdiet=volutpat&sapien=convallis&urna=morbi&pretium=odio&nisl=odio&ut=elementum&volutpat=eu&sapien=interdum&arcu=eu&sed=tincidunt&augue=in&aliquam=leo&erat=maecenas&volutpat=pulvinar&in=lobortis&congue=est&etiam=phasellus&justo=sit
/nunc/commodo/placerat/praesent/blandit.aspx?mauris=rutrum&vulputate=at&elementum=lorem&nullam=integer&varius=tincidunt&nulla=ante&facilisi=vel&cras=ipsum&non=praesent&velit=blandit&nec=lacinia&nisi=erat&vulputate=vestibulum&nonummy=sed&maecenas=magna&tincidunt=at&lacus=nunc&at=commodo&velit=placerat&vivamus=praesent&vel=blandit&nulla=nam&eget=nulla&eros=integer&elementum=pede&pellentesque=justo&quisque=lacinia&porta=eget&volutpat=tincidunt&erat=eget&quisque=tempus&erat=vel&eros=pede&viverra=morbi&eget=porttitor&congue=lorem&eget=id&semper=ligula&rutrum=suspendisse&nulla=ornare&nunc=consequat
?est=molestie&donec=lorem&odio=quisque&justo=ut&sollicitudin=erat&ut=curabitur&suscipit=gravida&a=nisi&feugiat=at&et=nibh&eros=in&vestibulum=hac&ac=habitasse&est=platea&lacinia=dictumst&nisi=aliquam&venenatis=augue&tristique=quam&fusce=sollicitudin&congue=vitae&diam=consectetuer&id=eget&ornare=rutrum&imperdiet=at&sapien=lorem&urna=integer
espn.com
https://espn.com
www.espn.com
https://www.espn.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}