re = /^rgb\(\s*([+-]?\d*\.?\d+(?:[eE][+-]?\d+)?)%\s*,\s*([+-]?\d*\.?\d+(?:[eE][+-]?\d+)?)%\s*,\s*([+-]?\d*\.?\d+(?:[eE][+-]?\d+)?)%\s*\)$/
str = 'rgb(111111111111111111111111111111111111111111111111111111111111111111111!'
# Print the match result
str.match(re) do |match|
    puts match.to_s
end