$re = '/((https?:\/\/)?www\.youtube\.com\/watch\?v=[-A-z0-9_]{11})(&feature=(youtu\.be|related|plcp|youtube_gdata_player|kp)|&app=desktop|&eurl=https?:\/\/[^ }&?|\]<]*|&frags=[A-z]{2}(,?[A-z]{2})*|&fmt=18|&ab_channel=[^ }&?|\]<]*)*/m';
$str = 'https://www.youtube.com/watch?v=AofKyizzAko&feature=youtu.be
http://www.youtube.com/watch?v=AofKyizzAko&feature=youtu.be
https://www.youtube.com/watch?v=--BHuKeveg4&app=desktop is linked from Está Rico
https://www.youtube.com/watch?v=8FBTN8rWrBE&feature=youtu.be&app=desktop
https://www.youtube.com/watch?v=-Ayydp7q_yA&eurl=http://www.thomashefferon.net/ is linked from Thomas Hefferon
https://www.youtube.com/watch?v=-RXLU2bwNFM&frags=pl,wn is linked from XebiaLabs
https://www.youtube.com/watch?v=-RcPZdihrp4&ab_channel=Netflix/ is linked from Wikipedia:Wikipedia Signpost/Single/2018-01-16
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;