# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=(?:[?&]))foo(?:=([^&#]+))?\b/foo=.../g;t' <<< "?foo=foo&foo=bar&foo&nonfoo=bar&nonfoo&foo#foo=bar"