# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.*Three.Link resp.*$"
test_str = ("09/10/18 20:06:07.581 DEBUG: (Radio) One.Link DONE\n"
"09/10/18 20:06:07.963 34, 0, 0, 0, 0, -99\n"
"09/10/18 20:06:08.591 DEBUG: (Radio) Two.Link request\n"
"09/10/18 20:06:08.601 DEBUG: (Radio) Three.Link resp: -1 abc-34664 0 10-Sep 12:06:02 0 .00 .00 .00 .00 0 0 0 -99 -99\n"
"09/10/18 20:06:08.601 DEBUG: (Radio) One.Link DONE\n"
"09/10/18 20:06:08.983 34, 0, 0, 0, 0, -99\n"
"09/10/18 20:06:09.600 DEBUG: (Radio) Two.Link request\n"
"09/10/18 20:06:09.611 DEBUG: (Radio) Three.Link resp: -1 abc-34664 0 10-Sep 12:06:03 0 .00 .00 .00 .00 0 0 0 -99 -9r9\n"
"09/10/18 20:06:09.611 DEBUG: (Radio) One.Link DONE")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.