const regex = new RegExp('(?P<type>deb(?:-src)?) (?:\\[(?P<options>.*)\\] )?(?P<uri>(?P<protocol>(?:(?:mirror\\+)?(?P<local>file|cdrom|copy)|(?P<remote>http|https|ftp|ssh))):(?(remote)//((?:(?!-)[a-zA-Z0-9-]{1,63}(?<!-)\\.)+[a-zA-Z]{2,6}))/[a-zA-Z0-1-_\\./]+) (?P<suite>[a-z/]+)(?:(?<!/) (?P<components>[a-z]+(?: [a-z]+)*))', 'u')
const str = `deb [signed-by=path] http://de.archive.ubuntu.com/ubuntu/ focal main universe restricted`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}