const regex = /'.*?'|".*?"|(\/\/[^\r\n]*|\/\*.*?\*\/)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\'.*?\'|".*?"|(\\\/\\\/[^\\r\\n]*|\\\/\\*.*?\\*\\\/)', 'gs')
const str = `
//get means only read, but not to mutate data
Get(BooksWithAuthors)
//default queries via mycel
.Query()
//junction table to pair books and authors
.From("BookAuthor".As(BA))
//main table for books
.Join(left: Books.As(B) => B.Id == BA.BookId)
//or select only that fields or objects you want to response
.Select(B)
.Foo("//wrong-comment-inside-quotes")
.Foo('//wrong-comment-inside-single-quotes')
.Foo(some /*wrong-comment*/ inside)
.Foo('some /*wrong-comment*/ inside')
;
//get means only read, but not to mutate data
Get(BooksWithAuthorsByMethod)
//using individual backside methods (created by own)
.GetBooksWithAuthors(id:6, filter:{key:'minAuthorAge', value:17})
;
/*
comments
"over"
*/
/*
'multiply
lines' //with wrong comments inside
*\\
aa"aasdfasdasdf
asdfasdfasdf
asdfasdf"asdfasd
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}