package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:\h*([a-z\h]+\b)\h*)?(?:\/([a-z\h]+)\/)?(?:\h*([a-z\h]+\b)\h*)?$`)
var str = ` Fred Joseph /Smith/
/Smith/
Fred Joseph
/Smith/ Fred Joseph
Fred /Smith/ Joseph`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}