package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{1,2}(.?\d{3}){2}-[\dkK]$`)
var str = `15.000.000-9
15000000-9`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}