$re = '/q(?<!sq(?=rtf)).?r/m';
$str = 'q?r
but not sqrtf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);