$re = '/\B\.\d+\b/m';
$str = 'The cat is .75 high but the dog id 3.67 high instead. All animals aren\'t higher that .87.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);