import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:\\(?(?:00|\\+)([1-4]\\d\\d|[1-9]\\d?)\\)?)?[\\-\\.\\ \\\\\\/]?)?((?:\\(?\\d{1,}\\)?[\\-\\.\\ \\\\\\/]?){0,})(?:[\\-\\.\\ \\\\\\/]?(?:#|ext\\.?|extension|x)[\\-\\.\\ \\\\\\/]?(\\d+))?$";
final String string = "(+351) 282 43 50 50\n"
+ "90191919908\n"
+ "555-8909\n"
+ "001 6867684\n"
+ "001 6867684x1\n"
+ "1 (234) 567-8901\n"
+ "1-234-567-8901 x1234\n"
+ "1-234-567-8901 ext1234\n"
+ "1-234 567.89/01 ext.1234\n"
+ "1(234)5678901x1234\n"
+ "(123)8575973\n"
+ "(0055)(123)8575973";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}