$re = '/^\d*\.\d+$/m';
$str = '100
10.2
0.5
0.
.5
-0.5
+0.5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);