package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^-?\d*(\.\d+)?$`)
var str = `100
10.2
0.5
0.
.5
-0.5
-100
abcd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}