$re = '/^[a-zA-Z0-9 ]*$/m';
$str = 'hello90
what
how are you
hi5
8ask
yyy.
3434';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);