#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^(?=.*Mass.Effect)(?!.*Mass Effect Trilogy).*|Mass Effect - All Media Types)"
Local $sString = "Mass Effect" & @CRLF & _
"Mass Effect Trilogy" & @CRLF & _
"Mass Effect - All Media Types"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")