$re = '/^\d{4}(32|33|93|94)\d{4}$/';
$str = '9860341386';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);