re = /\b(?:Sunscreen|Lubricant)\h+\d+(?:g|ml)\h+\((\d+)\h+Quantity\)/
str = 'Sunscreen 25g (200 Quantity)
Lubricant 100ml (50 Quantity)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end