package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<%([-=]):\s*([^|]*?)\s*%>`)
var str = `<%=: price %>`
var substitution = "<%\1 \2 %>"
fmt.Println(re.ReplaceAllString(str, substitution))
}