re = /\b(?!0\b)\d+\b/m
str = '0;0;0;0;0;0;0;0;0;0;51;0;0;0;0;0;0;0;0;0;0;51;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0;0'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end