re = /<(\"[^\"]*\"|'[^']*'|[^'\">])*>/i
str = '<a href="tab0"> Link </a><p> sfdsfd</p>
<ins>
"djjdhb"
</ins >'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end