package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)wpsite\.com\/wp-json\/wp\/v2\/posts\?tags\[]=6287&tags\[]=6289&_fields`)
var str = `https://wpsite.com/wp-json/wp/v2/posts?tags[]=6287&tags[]=6289&_fields=jetpack_featured_media_url,title.rendered,excerpt.rendered,link,id&per_page=100&page=1&orderby=date`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}