$re = '/^(\d+)[\)\-\s]*(.*)/im';
$str = '5 - 800w Jokers
12 - 25\' Stingers
5) 25\' Stingers
12-25\'Stingers
5)25\' Stingers
5 25\' Stingers
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);