$re = '/(?|"([^"]+)"|(\S+))/m';
$str = '"word" "word1 word2 a" word3 "w k"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);