const regex = /[เแโไใ]{2,}|[ิีึืูุั็]{2,}|[่้๊๋]{2,}|[์]{2,}|[่้๊๋][ิีึืุูั็]|(?<![ก-ฮ][่้๊๋]?)[ิีึืุูำ็ั]|[เแโไใ][ิีึืุูั็าะำ]|(?<![ก-ฮ][ิุ]?)(?:์)|(?:ั)(?![่้๊๋]?[ก-ฮ](?![ะาิีึืุูำั็่้๊๋์อ]|ว[ก-ฮ]))|(?:ื)(?![่้๊๋]?[ก-ฮ](?![ะาิีึืุูำั็่้๊๋์]))|แ[ก-ฮ]็(?)|(?<![ก-ฮ][ิีืึุูั]?)[่้๊๋]|[เแไโใ](?![ก-ฮ])|(?:[ไใ][ก-ฮ][่้๊๋]?[ะาิีึืำั็์]|[โ][ก-ฮ][่้๊๋]?[าิีึืำั็์]|แ[ก-ฮ][่้๊๋]?[าิีืึุูำั์]|เ[ก-ฮ][่้๊๋]?[ึุูำั์])|(?<!เ[ก-ฮ]{1,2}[่้๊๋]?[าอ]|[โเแ]?[ก-ฮ]{1,2}[่้๊๋]?)ะ|(?<!เ?[ก-ฮ]{1,2}[่้๊๋]?|า)า|เ(?![ก-ฮ][่้๊๋]?อ?)|เ[ก-ฮ](?:ี(?![่้๊๋]?ย)|ื(?![่้๊๋]?อ))|(?:[แเโไใ][ก-ฮ]|[ก-ฮ][ิีึืุูาะ])(?:ำ)|(?:ำ)[่้๊๋]|(?<![เแไใโ][ก-ฮ]?)[ก-ฮ](?![ิีึืุู])[่้๊๋](?!(?:[ะำา]|[ว][ก-ฮ]|อ?[ก-ฦศ-ฮ](?![ะาิีึืุูำั็่้๊๋])))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[เแโไใ]{2,}|[ิีึืูุั็]{2,}|[่้๊๋]{2,}|[์]{2,}|[่้๊๋][ิีึืุูั็]|(?<![ก-ฮ][่้๊๋]?)[ิีึืุูำ็ั]|[เแโไใ][ิีึืุูั็าะำ]|(?<![ก-ฮ][ิุ]?)(?:์)|(?:ั)(?![่้๊๋]?[ก-ฮ](?![ะาิีึืุูำั็่้๊๋์อ]|ว[ก-ฮ]))|(?:ื)(?![่้๊๋]?[ก-ฮ](?![ะาิีึืุูำั็่้๊๋์]))|แ[ก-ฮ]็(?)|(?<![ก-ฮ][ิีืึุูั]?)[่้๊๋]|[เแไโใ](?![ก-ฮ])|(?:[ไใ][ก-ฮ][่้๊๋]?[ะาิีึืำั็์]|[โ][ก-ฮ][่้๊๋]?[าิีึืำั็์]|แ[ก-ฮ][่้๊๋]?[าิีืึุูำั์]|เ[ก-ฮ][่้๊๋]?[ึุูำั์])|(?<!เ[ก-ฮ]{1,2}[่้๊๋]?[าอ]|[โเแ]?[ก-ฮ]{1,2}[่้๊๋]?)ะ|(?<!เ?[ก-ฮ]{1,2}[่้๊๋]?|า)า|เ(?![ก-ฮ][่้๊๋]?อ?)|เ[ก-ฮ](?:ี(?![่้๊๋]?ย)|ื(?![่้๊๋]?อ))|(?:[แเโไใ][ก-ฮ]|[ก-ฮ][ิีึืุูาะ])(?:ำ)|(?:ำ)[่้๊๋]|(?<![เแไใโ][ก-ฮ]?)[ก-ฮ](?![ิีึืุู])[่้๊๋](?!(?:[ะำา]|[ว][ก-ฮ]|อ?[ก-ฦศ-ฮ](?![ะาิีึืุูำั็่้๊๋])))', 'gm')
const str = `กาแฟร้อนๆ มีกลิ่นหอมฟุ้งไปทั่วห้อง เด็ก ๆ กล้อนผมก็วิ่งเล่นอย่างสนุกสนาน เพียงผู้หญิงคนนั้นกัดผมเดินผ่านไปอย่างรวดเร็ว ใบไม้ร่วงหล่นลงมาเป็นจำนวนมาก ฉันชอบกินผลไม้สดๆ ทำให้ร่างกายแข็งแรง โดยเฉพาะแตงโม สมุทรสาครเป็นจังหวัดที่อยู่ใกล้กรุงเทพฯ เขาแต่งกลอนแล้วพูดว่า "ไม่เป็นไร" แล้วยิ้มให้อย่างแกล้วกล้า นักเรียนทุกคนต้องใส่เครื่องแบบ ดอกไม้บานสะพรั่งในสวน ฤดูฝนปีนี้มีน้ำมาก ญาติๆ มาเยี่ยมเยือนบ้านเป็นประจำ ธรรมชาติสวยงามมาก ฌานสมาธิช่วยให้จิตใจสงบ ปลาทูทอดกรอบอร่อยมาก แม่ซื้อของมาเต็มตะกร้า พ่อขับรถไปทำงานทุกวัน ไก่ตัวนั้นขันดังมาก เธอใจดีมากๆ เลย ชาวบ้านชุมชนไม่สนใจความละเอียดละออ เคล้าความงมงาย มะขามเปรี้ยวมะเขือหวานอร่อยมาก อยากตื่นเต้นดีใจจริงๆ ถ้าเทียบความดั้งเดิมทำไมคนแซ่ตั้งดี เขาว่าอย่าอยู่อย่างอยาก อย่ามาชวนทะเลาะได้ไหม เอาอะไรมาอีกเนาะโมเมไป แบบว่าอำนาจใหญ่โต แบบนี้นั่นนี่โน่น กล้าเกล้ามาดู เงื่อนไขเหล่านี้ เรื่องราวเรื่อยเปื่อย เสื้อผ้าสวยงาม เหมือนเดิมทุกอย่าง คือแกงเผ็ดแกงจืด ใจเย็นใจร้อน เตียงนอนเตาไฟ เกลือป่นพริกไทย เตาไฟลั่นดังเปรี๊ยะ ๆ เปลือกหอยกระเทาะออกมา เหาะเหินเดินอากาศ โบยบินไปในอากาศทุกอย่างโบ๋เบ๋ มาเราจะไปเที่ยวหัวหิน เมากันให้เละเทะและแทะไปเลย สักครู่นึงก็ได้เนื้อหาตุ๊ดตู่ปู่บู้บี้ละ ดีไม่ดีก็ลองดู ก็โน๊ะ หาโอกาสคุยกันหน่อยกับพวกเกรียนคีย์บอร์ด สัตว์ที่อาศัยลำนำลำน้ำแคว เทพีเพรียงเดินเพลิดเพลินเหลือคนาเพียงใจ ดับเบิ้ลเปิ้น กล้องถ่ายกล้วยล้มส้มใหญ่ไปไม่ได้ใกล้ ๆ หรือไกลก็ได้ ลองดูคำประหลาดๆ หน่อย เช่น แข็งทื่อ โกโก้ เกล้อะ โกล้ะ เกละ แกละ กละ กลาก เกลื้อน กมลสันดารเป็นไปเพื่อความสนุกสนาน และใช้บัตรทองความศักดิ์สิทธิ สวาร์มซี๊ดส์ซัดส์คอมพิวเตอร์สวมสเกิร์ทนอนเกร็งเฉิ่ม เปิดสวิทช์มีเซ็กซ์ในสตาร์ทอร์ชเสปิร์มยิ้มแฉ่ง หลายกิโลวัตต์ ถูกแฮ็กซ์คอนเฟิร์ม คอมพิวเตอร์ กราฟ สเกิร์ท ชีส ซัดส์ ดัชท์ สวิทช์ เซ็กซ์ วัตต์ เสปิร์ม สตาร์ แบลคลิสต์ ไวท์ลิสต์ ฟีสต์ เธอยอมร่วมมือป่าว โอ้ยๆ โอดโอยเอย ยานอวกาศพุ่งทะยานว่องไว ผล็อยหลับ ชื่อย่อมสะท้อนประสบการณ์ มังกรวสันต์ สิบวสันต์ ร้อยวสันต์ อวมงคล นวเวทย์ วนอุทยาน ขวนขวาย รวบรวม จวนตัวสัตว์แพทย์ ชู่ แองเจลิกา มาร์เกริตา ทะเลก็ทำให้เกิดคลื่นสูง หน้าที่ของวณิพก ไม่ว่าจะแลกด้วยอะไรก็ตาม
กาาแฟร้้อนๆ มีกลิ่ินหอมฟุ้งไปทั่ัวห้อง เด็็ก ๆ กล้อนผมก่็วิิ่งเล่่นอย่างสนุ่กสนาน เพีผู้หญิิงคนนัันกัผมเดินผ่านไปอย่างรวเร็ว ใบไมัร่วงหล่นลงมาเป็นจำนวนมาก ฉันชอบกินผลไม้สดๆ ทำให้ร่างกายแข็แรง โโดยเฉพาะแตงโม สมุทรสาครเป็นจังหวัดที่อยู่ใกล้กรุงเทพฯฯ เขาแต่งกลอนพูดว่า "ไม่เป็ไร" แล้วยิ้้มให้อย่งแกล้วกล้า นักเรียนทุกคนต้องใใส่เครื่องแบบ ดอกไม้บานสะพรั่งในืสวน ฤดูฝนปีนี้มีน้ำมาก ญาติๆ มาเยี่อมเยืยนบ้านเป็นประจำ ธรรมชาติสวงามมาก ฌานสมาธิช่วยให้จิตใจสงบ ปลาทูทอดกรอบอร่่อยมาก แม่ซื้อของมาเต็่มตะกร้า พ่อขัรถไปทำงานทุูกวัน ไก่ตัวนั้นขันดังมาก เธอใจดีมาาาาาาาาากๆๆ เลย ชาวบ้านชุุมชนไไม่สนใจความละเอียดละออ เคล้้าความงมงาย มะะขามเปร้ียวมะเขือหวานอร่อยมาก อยากตื่นเต้้นดีใจจริงๆ ถ้าเทียบความดั้งเดิมเทำไมคนแซ่ตั้งดี เขาว่าอย่าอยู่อย่างอยาก อย่ามาชวนทะเลาะได้ไหม เอาอะไรมาอีกเนาะโมเมีไป แบบว่าอ่ำนาจใหญ่โต แบบนี้นั่นนี่โนีน กล้าเกล้ามาดู เงื่อนไขเหล่านี้ เรื่องราวเรื่อยเปื่อย เสื้อผ้าสวยงาม เหมือนเดิมทุกอย่าง คืแกงเผ็ดแกงจืด ใจเย็นใจร้อน เตียงนอนเตาไฟ เกลือป่นพริกไทย เตาไฟลั่นดังเปรี๊ยะ ๆ เปลือกหอยกระทาะออกมา เห็าะเหินเดินอากาศ โบ็ยบินไปในอากาศทุกอย่างโบ๋๋เบ๋่ มาเราจะไปเที่ยวหัวหิน เมากันให้เละเทะและแทะไปเลย สักครู่นึงก็ได้เนื้อหาตุ๊ดตู่ปุีบู้บี้ละ ดีไม่ดีก็ลองดู ก็่โน๊าะ หาโอาคุ้ยกัันหน่อย กับพวกเกรียนคีย์์บอร์ด สัตว์ที่อาศัยแลำนีำลำน้ำแคว เทพีเพรียงเดิเพลิดเพลินเหลืคนาเพีใจ ดับเบิ้ลเปิ้น กล้ถ่ายกล้ล้มส้มหญ่ไปไม่ได้ใกล้ ๆ หรือกลก็ได้ ลองดูคำประหลาดๆ หน่อย เช่น เขึงแทื่อ โกาโก์ เกล้อะ โกล้ะ เกละ แกละ กละ กลาก เกลื้อน กมลสัดารเป็นไปเพื่อความสนุกสนาน และใช้บัตรทองความศัดิ์สิทธิ์ สวาร์มซืส์ซัส์คอมพิวเตอร์สวมสเกิร์ทนอนเกร็งเฉิ่ม เปิดสวิช์มีเซ็ซ์ในสตาร์ทอร์ชเสปิร์ยิ้มแฉ่ง หลายกิโลวัต์ ถูกแฮ็ซ์คอนเฟิร์ คอมพิวเตอร์ กราฟ สเกิร์ท ชีส ซัดส์ ดัชท์ สวิช์ เซ็ซ์ วัตต์ เสปิร์ สตาร์ แบลคลิสต์ ไวท์ลิสต์ ฟีต์ เธอยอมร่วมมือป่าว โอ้ยๆ โอดโอยเอย ยานอวกาศพุ่งทะยานว่องไว ผล็อยหลับ ชื่อย่อมสะท้อนประสบการณ์ มังกรวสันต์ สิวสันต์ ร้อวสันต์ อวมงคล นวเวทย์ วนอุทยาน ขวนขวาย รวบรวม จวนตัวสัตวแพทย์ ชู่วววววววววววว แองเจลิกา มาร์เกริตา ทะเลก็ทำให้เกิดคลื่นสูง หน้าที่ของวณิพก ไม่ว่าจะแลกด้วยอะไรก็ตาม`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}