$re = '/^(?!.*_)(?!.*:).+$/m';
$str = 'hai
hello
amount_10
amount_90
total:100
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);