$re = '/\b\d+/\d+/\d+.*?(?=\s*\b\d+/\d+/\d+|$)/';
$str = '28/11/2016 Mushroom 05/12/2016 Carrot 12/12/2016 Broccoli 19/12/2016 Potato';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);