import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^bead$";
final String string = "Match ENTIRE LINE of these lines:\n\n"
+ "accede\n"
+ "babe\n"
+ "bead\n"
+ "bedded\n"
+ "bedeaf\n"
+ "caffa\n"
+ "dace\n"
+ "daff\n"
+ "dead\n"
+ "deface\n"
+ "faded\n"
+ "feed\n\n\n"
+ "and NONE of these lines:\n\n"
+ "beam\n"
+ "buoy\n"
+ "canjac\n"
+ "chymia\n"
+ "corah\n"
+ "idic\n"
+ "lucy\n"
+ "martyr\n"
+ "matron\n"
+ "relose\n"
+ "sonly\n"
+ "widish";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}