import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![\\p{L}0-9])([##][·・ー_0-90-9a-zA-Za-zA-Zぁ-んァ-ン一-龠]{1,24})(?![\\p{L}0-9])";
final String string = "Hashtag must be started with # character.\n"
+ "Hashtag will be detected by space character and other special characters (!,@,&,*,%,$).\n"
+ "Example 1: Hello#guys. This is a #test. -> Valid hashtag: #test.\n"
+ "Example 2: Hello#guys. This is a #test!#message. -> Valid hashtag: #test and #message\n"
+ "Example 3: Hello#guys. This is a #test #message. -> Valid hashtag: #test and #message\n"
+ "Example 4: Hello#guys. This is a #test#message. -> Valid hashtag: #test\n"
+ "Example 5: #asdasdasdasdasdasdasdasdasd -> Valid hashtag: none\n"
+ "Example 6: # -> Valid hashtag: none\n"
+ "#日本語#asd => Valid hashtag should be #日本語\n"
+ "#日本語日本語日本語日本語日本語日本語日本語日本語日本語 => Will not a valid hashtag";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}