const regex = /(?<=(?:^|\.)([^.]+))(?=(\ba\w*\sa\w*[^.]+))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=(?:^|\\.)([^.]+))(?=(\\ba\\w*\\sa\\w*[^.]+))', 'gm')
const str = `I know them well. They are extremes, abnormals; their temperaments are as opposite as the poles. Their life-histories are about alike but look at the results.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}