const regex = /^[^\s@]+@(?:[^\s@.]+\.)*canada\.ca$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\s@]+@(?:[^\\s@.]+\\.)*canada\\.ca$', 'gm')
const str = `joe@canada.ca
joe@it.canada.ca
joe.smith@business.canada.ca
joe@visitcanada.ca`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}