$re = '/(?:\G ?)[A-Z]+(?= |$)/m';
$str = 'NEW APPLE IPHONE X 64GB CVX-Dk46';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);