use strict;
my $str = 'line1
line2
line3
line4
line5
';
my $regex = qr/(\r?\n)?(?:\r?\n){2,}/mp;
my $subst = '$1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";