import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[^\\d\\n]*\\d)(?=[^A-Z\\n]*[A-Z])(?=[^a-z\\n]*[a-z])(?=[^-!@._*#%\\n]*[-!@._*#%])[-A-Za-z0-9=!@._*#%]*$";
final String string = "thisisSOSmepassword#\n"
+ "T#!sIsS0om3%Password\n"
+ "thisisSOSmepassword12\n"
+ "thisissommepassword12#\n"
+ "THISISSOMEPASSWORD12#\n"
+ "thisisSOMEVALIDP@SSWord123\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}