$re = '/\{[^\{]+?}/';
$str = '{here {first} and {second} and {third }}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);