re = /(ATG.*?TGA)/m
str = 'TCAGGCATGCCCCTCCTCATCGCTGGGCACAGCCCAGAGGGTATAAACAGTGCTGGAGGCTGGCGGGGCAGGCCAGCTGAGT'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end