const regex = /(?=.{20}).*?(?=(?<ch>[@#$^]))(?<match>\k<ch>{6,}).*(?<=.{10})\k<match>.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=.{20}).*?(?=(?<ch>[@#$^]))(?<match>\\k<ch>{6,}).*(?<=.{10})\\k<match>.*', 'gm')
const str = `Cash\$\$\$\$\$\$Ca\$\$\$\$\$\$sh
\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$\$
aabb
th@@@@@@eemo@@@@@@ey
validticketnomatch:(
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}